Where are bindings "alpha" coming from?

I’m running into an issue when deploying from bundle.

A lot of the LXC containers are in down state with message:
matching subnets to zones: cannot use space "alpha" as deployment target: no subnets

I haven’t declared any binding called alpha on the bundle. Juju seems to have auto populated it from somewhere.

I deployed using this bundle

Here’s the juju status output from the model

Here’s the juju export-bundle from the running model after deployment.

Check out the weird bindings on the bundle export

This has been reported. I’m looking at it now.

Can you try setting a default space for the model and reattempting the deployment?

Perhaps something like this:

juju model-config default-space=internal-network

Alternatively, make sure you supply a default binding for all deployments. For example, instead of:

juju deploy postgres --bind "db=public-network"

Use:

juju deploy postgres --bind "private-network db=public-network"

Juju has had the default-space configuration option for a while now. It is the space that Juju uses for default bindings if they are not explicitly set.

Out of the box it is set to “alpha”, which is Juju’s initial space. For a MAAS deployment, which defines its own space topology, alpha will have no subnets. For all other providers, all subnets will be in the alpha space initially.

Recent fixes for provisioning hosts in correct subnets/AZs has made this behaviour manifest.

I’ve included default-space in the model configuration documentation.

Please take a look and let me know if we can improve these docs further.

@manadart thanks for the response.

Let me try those few things and get back to you