OSM Development Stack

Hello,
I created a new ubuntu VM on VirtualBox and have started trying the procedure. On microstack.init I get “stack smashing detected” after waiting RabbitMQ to start:
image
Note that I have used the new ubuntu 19.04 and not the 18 one.

With Ctrl-C I get below traceback:

At this point, in my juju status I have:

(too bad that I can’t upload more than 1 picture due to being a new member… perhaps you should change this restriction to something more logical… i.e. 5)

…Forgot to mention…
Great article :slight_smile:

I installed a fresh ubuntu 18.04 (ubuntu-18.04.3-live-server-amd64) and retried.
I got to an error:

after: juju deploy osm --overlay vca-overlay.yaml

I tried many things (mostly trying to troubleshoot dns) but they did not work.
In my last attempt (starting from fresh ubuntu installation) I added the command:

before installing osmclient snap … and it worked:

I’m starting to get tired of this bundle. It supposed to make my life easier but I’ve already spent 2 days debugging things.
So, OSM and microk8s have been installed, but microstack fails with errors (at: sudo microstack.init --auto):

and a few lines below:

Below is a huge clipping of my terminal. Again, it is very bad that you have so many new member rules applied… I can’t post 2nd screenshot and I can’t upload a file (.rtf, .pdf) of my terminal outputs… This makes sharing my problem and asking for advice very difficult.
Anyway, below is the clipping of the error:
image

Note that I have tried numerous times on –channel=edge/rocky and once on –channel=edge. Same error. Funny thing is that yesterday, on my other installation I got the same error a few times, but then had an idea and resolved it. But I can’t remember what I did trying around staff. Certain thing is that I deviated from the procedure above. I kept the terminal log until the point of the problem but sadly not the solution. So, in this installation I came to a dead end.

So, if I get no response from you in the next days… I guess I’m dropping it

Hey @dkaratasos,

Thanks for testing out the new dev stack. Sorry to hear you’ve run into so many troubles with it!

Most of the team has just traveled back from the Hackfest in Patras, so it may take a day or two for them to respond. We’re eager to understand the problems you faced, so we can make the experience better for everyone.

Thanks!

Adam

Thanks for replying. I will wait for the team to come back then :slight_smile: hope they enjoyed their visit in Patras

Hello @dkaratasos ,

Sorry to hear you have had so many problems during the installation. I will go through some of the problems you’ve had.

First of all, I want to make sure you have been using Ubuntu 18.04 (LTS). How much memory and disk do you have on your VM? I would recommend you 16 GB of RAM, and 100 GB of disk.

At the end of the answer, there is a “Following steps” section with the steps I would recommend you to do.

DNS problem

This issue you have attached could be because you are behind a proxy which hasn’t access to api.jujucharms.com.

Also, make sure you are installing the 1.14 version of microk8s. There’s an open bug with the microk8s 1.15 DNS plugin, which will be fixed soon.

Also, I don’t think you need to execute sudo iptables -P FORWARD ACCEPT

Stack smashing detected [UPDATED]

I’ve submitted the bug, and the team is fixing it right now. I believe it’s an issue affecting ubuntu 19, so try using bionic instead.

https://bugs.launchpad.net/microstack/+bug/1844257

Following steps

  • Create a fresh VM with the recommended settings.
  • Follow this in order to improve the performance of your VM.
  • Follow the steps until Install Microstack (not included)
  • Do watch -c juju status --color to check the OSM deployment status. Wait until OSM is up.
  • Install microstack

Contact

Feel free to send me an email with your progress.
david.garcia@canonical.com

Hello David,

Let me confirm first that I am using Ubuntu 18.04 LTS as mentioned above on a fresh VM installation on vbox at each attempt. Regarding resources, I gave the VM 16GB memory, ~80GB disk and 4CPUs as recommended.
I keep monitoring the juju status during deployment and on the problem of: “ERROR cannot deploy bundle: cannot add charm “cs:~charmed-osm/grafana-k8s-21”:” the juju status could not give a printout at all. With my workaround on iptables I didn’t see any issue on juju status.

I am not behind a proxy on home computer that I tried installation.

My current problem is Microstack, so I can’t really follow the installation step on your instructions. Enhancements on performance are highly appreciated, but I’m trying to figure out the problem before trying from scratch for a 4th/5th time.

I will use your email to send you a command log from MobaXterm since I can’t upload it here :slight_smile:

Thanks,
Dimitris

Hello @dkaratasos,

Please, attach the output from microk8s.kubectl -n kube-system get pods command.

I want to make sure that the DNS plugin is up and running.

Thanks,
David

I have checked this on one of the terminals… the DNS was running. I haven’t kept a sceenshot of that but I will next time I’ll start it up. I have send you an email with the main terminal output :slight_smile:
My other terminal was mainly used to check juju status kube-system pods etc, so I didn’t save it afterwards…

Hmmm… strange…
I was always doing fresh installations before and haven’t really got a chance before to power off and power on the VM. Today, to get the printout you requested I powered it on again… but juju status printouts nothing (it is hanged) and get pods gives status unknown. About an hour has passed from powering on.
image
i would swear that they were both ok last time I had it opened. I even tried the microstack init after everything on juju status appeared running.

At any case, the settings of the VM is also shown above… (I had to combine 3 images into one)

I can also see an error if I use the -A in get pods:
image

maybe it is relevant…

Having an issue installing as well.

sudo snap install juju --classic
sudo snap install osmclient --edge
sudo snap connect osmclient:juju-client-observe

Probelem when I run “snap connect osmclient:juju-client-observe” I get an error that
error: snap “osmclient” has no plug named “juju-client.observe”

Will be glad to know how i can get past this issue.
The rest are fine so far.

Thank you so much,

Michael

Hello Michael

It looks that this post is not completely updated. You can follow the instructions to install Charmed OSM in this link of the ETSI OSM documentation

Please let me know if this works for you.

Best regards,

Guillermo

Hello Guillermo,

I have installed charmed OSM from the above link and Microstack on the same VM. Everything went well and I was able to desploy the test Network Service.

However, I cannot see the OSM parameters on Grafana dashboard. I do not find the ‘osm_mano_automated’ dashboard in Grafana.

Additonal note, when I reboot the VM, some of the units including mon-k8s under juju status show the agent failed. Is there a way to refresh/restart juju charms.

Any help is much appreciated.
Thank you.

Hello Anusha,

Sorry for the late answer.
Regarding the Grafana dashboard, this is a known issue. You can import the dashboard manually. You can find OSM dashboards in devops repository in /installers/docker/grafana folder. The dashboards you need to import are: osm-sample-dashboard.json and osm-system-dashboard.json.

And regarding the status of mon-k8s, it takes some minutes to the pod in order to be available. In case, the issue persists, then try the following commmand that will restart the agent:
microk8s.kubectl -n osm delete pods mon-k8s-operator-0 --force --grace-period 0

I hope this helps.

Hi Anusha,

2 questions:

  1. The link from ETSi installs OSM as well as micro k8s, right?
  2. Can you please share the link you used for installing microstack?

Thanks,
Nishank

Hi Galvino,

Thanks for the response.
I think something went wrong during my charmed osm installation and Grafana is not configured properly. However, I was able to query the metrics via osm_prometheus under ‘Explore’

Regarding the juju status, the above command did not work and I’m yet to find out how to restart terminated components.

Hi Nishank,

  1. Yes. Here is the link : https://osm.etsi.org/docs/user-guide/03-installing-osm.html#charmed-installation
  2. For microstack : https://ubuntu.com/tutorials/microstack-get-started#2-install-microstack

All the best!
Best Regards,
Anusha

Thank you for the links, Anusha.

Have installed OSM via ETSI link.
We do not explicitly need to add microk8s to OSM, like say we add a VIM (openstack), right?

Onto microstack now.

Thanks again,
Nishank

Hello,

I have followed the isntructions and have managed to install OSM Charmed but I’m having an issue with setting up my the Basic network service example as shown in this page.

While I am able to download and upload the packages into OSM, after using the create a basic network service command in my terminal that status stays at building and does not move any further.

Could you help me with this please as im unsure where to go from here. Let me know if there is any further information that I need to provide as well.

Cheers,
Rajiv