Openstack upgrade to train missing lb

Hello everyone.
After the upgrade to train the dashboard doesn’t show anymore the loadblancer tab.
I tried to reconfigure but I’ve the same result:

juju config openstack-dashboard neutron-network-lb=true
In the stain release I created a loadbalancer and now it keeps working even if I cant’ see anymore in the dashboard.

Sorry about the lack of response @cardax. I’ve added a link to this question within the #openstack-charms IRC channel in Freenode. Hopefully someone will be able to answer soon.

Hello @cardax

The in-tree loadbalancer code has been deprecated for some time in the upstream OpenStack Neutron project. As of Train it was removed [0].

The Octavia project replaces and extends the functionality and there are charms available. There is a separate subordinate charm for the dashboard component.


Hello @fnordahl
Thank you to you reply.
After posting my help request I also found your link. In the dashboard charms train is still present the config to enable the neutron lb. Anyway I tried to deploy the Octavia solution without success. Today I’ll try again on the test environment.
Information like this should be on the top front of the upgrade documents. To avoid problem to production.

Each release of the OpenStack Charms encapsulate support for all supported release combinations of Ubuntu and OpenStack. Consequently the neutron-network-lb configuration option is still valid for the charm when deployed with OpenStack releases prior to Train. There should probably be a note on the description of that configuration option about which releases are supported though.

For upgrading OpenStack we have a collection of useful information in the OpenStack Charms Deployment Guide. As mentioned in the upgrades section of the OpenStack operations guide (referenced here) we recommend reviewing the release notes of the individual OpenStack components important to you prior to attempting an upgrade.

We work hard to facilitate or automate upgrades of the most used configurations where possible and with the breath of components and configurations supported in the charms it is unfortunately not possible to encapsulate every detail in the charms release notes.

Good information is worth repeating so we should probably add a section about the Neutron load balancer removal to the Known OpenStack upgrade issues section of the upgrade guide.

Anyway seems there is a problem about octavia and the train release openstack.
I deployed following the guide the charm went in the error state and inside the debug log there is:
RuntimeError: Release queens is not supported by this charm. Earliest support is rocky release

So there is no native loadbalancer solution for train openstack installation.

The error message indicates you are attempting to deploy Octavia on a system with Queens packages. This is not supported.

What is the value of the openstack-origin configuration option for the Octavia charm?

You can retrieve the value by executing the following command:

juju config octavia openstack-origin

Charm Openstack origin is train. A fresh new deployment made today.
Origin for Octavia i tried also keep Rocky or train with same result.

Could you please paste the output from the juju config octavia openstack-origin command verbatim?

The openstack-origin configuration option has a specific format.

There is also an overlay bundle you can use as a template in conjunction with the OpenStack Base bundle.

this is the output.

maas-region-x01:~$ juju config octavia openstack-origin

I also post the full error:

unit-octavia-1: 12:10:23 ERROR unit.octavia/1.juju-log Hook error:
Traceback (most recent call last):
File “/var/lib/juju/agents/unit-octavia-1/.venv/lib/python3.6/site-packages/charms/reactive/”, line 74, in main
File “/var/lib/juju/agents/unit-octavia-1/.venv/lib/python3.6/site-packages/charms/reactive/”, line 390, in dispatch
File “/var/lib/juju/agents/unit-octavia-1/.venv/lib/python3.6/site-packages/charms/reactive/”, line 359, in _invoke
File “/var/lib/juju/agents/unit-octavia-1/.venv/lib/python3.6/site-packages/charms/reactive/”, line 181, in invoke
File “/var/lib/juju/agents/unit-octavia-1/charm/reactive/”, line 21, in default_install
with charm.provide_charm_instance() as instance:
File “/var/lib/juju/agents/unit-octavia-1/.venv/lib/python3.6/site-packages/charms_openstack/charm/”, line 95, in enter
return BaseOpenStackCharm.singleton
File “/var/lib/juju/agents/unit-octavia-1/.venv/lib/python3.6/site-packages/charms_openstack/charm/”, line 305, in singleton
package_type=package_type or ‘deb’)
File “/var/lib/juju/agents/unit-octavia-1/.venv/lib/python3.6/site-packages/charms_openstack/charm/”, line 135, in get_charm

“is {} release”.format(release, known_releases[0]))
RuntimeError: Release queens is not supported by this charm. Earliest support is rocky release

Looks like you are missing the ‘cloud:’ prefix. Try cloud:bionic-rocky

@gnuoy you are right the documentation report wrong origin config:

After change to cloud:bionic-train everything works fine.
thanks all for the help.

1 Like

Sorry about the mistake. I’ve raised to get it fixed.

Anyway was more simple to use the neutron solution. I will not upgrade production for this change. I’ve to understand better the functionality of Octavia. Do you think on the future release will be already inside the openstack charm?