Changes in openstack-base bundle

Hi, I have installed openstack-base bundle two-months ago and had a good time adding kuryr-libnetwork service with zun and docker manually using openstack docs ( Everything went smooth and worked. But what happened a week ago is that when I reinstalled my openstack-base bundle train eddition, installed kuryr-libnetwork service and ran “docker run --net test_net cirros ifconfig” command I got error:

docker: Error response from daemon: failed to create endpoint condescending_bhabha on network test_net: NetworkDriver.CreateEndpoint: vif_type(binding_failed) is not supported. A binding script for this type can’t be found.

As far as I googled I understand that it is something wrong from neutron side. So, the thing is that I didn’t touch any neutron settings and I however don’t have previous neutron config files (when openstack worked)

Question is, maybe someone could explain what changed with neutron.conf files comparing with openstack-base (Stein release)? It would help me to resolve my issue :slight_smile:

Sharing link with a detailed info:

Hi @madness31,

As far as I know, there is no charm for Kuryr.

The best answer is that Kuryr should be charmed and integration-tested before it is consumed in production.

If you’re interested in exploring that (writing a charm), I’d encourage you to engage with the OpenStack Charms project with discussion and feature specification.

Beyond that, the proposition of manually configuring an OpenStack endpoint or service is not one that I personally recommend in any case where deployment reproducibility, stability, and supportability are important.



Hi, @beisner, finally I found what has changed. The thing is that now every time when you add a kvm node with a juju add-unit nova-compute command it installs node with a host name node1.maas. And it works well if you use only kvm hypervisor and create VM’s. But I know it is possible to use docker containers with juju openstack installation and after these changes kuryr doesn’t work.

When everything worked for me (1 month ago) the name of my node was without .maas ending:

Is it possible to change their host names (not hostnames) to previous ones (without .maas ending) via juju cmd?

Does anyone have any clue? Because now I have to change “host” line from compute.maas to compute each time in /etc/nova/nova.conf and /etc/neutron/neutron.conf and remove openstack compute service with .maas ending even if node reboots