Can't make juju spawn focal instances in Azure

I wanted to start playing with wireguard, and I was going to deploy it into Azure to make a tunnel to from my personal machine. I want to do this on top of focal, since wireguard is built into focal’s kernel.

But I can’t seem to create focal instances in Azure. I tried both centralus and uksouth region in case that mattered:

First I tried creating a focal controller and that failed like this

laney@nightingale> juju bootstrap --bootstrap-series=focal --config default-series=focal azure/uksouth azure-uksouth
Creating Juju controller "azure-uksouth" on azure/uksouth
Looking for packaged Juju agent version 2.8-rc1 for amd64
No packaged binary found, preparing local Juju agent binary
Launching controller instance(s) on azure/uksouth...
ERROR bootstrap failed, destroying model: cannot start bootstrap instance: selecting SKU for focal: Ubuntu SKUs for released stream not found
ERROR failed to bootstrap model: cannot start bootstrap instance: selecting SKU for focal: Ubuntu SKUs for released stream not found

Thinking that it might be a peculiarity of controllers, I bootstrapped with bionic and then tried to deploy cs:ubuntu on focal - which is supported per its metadata, and works locally on LXD — but that didn’t work either:

laney@nightingale> juju deploy cs:ubuntu --series focal
[ some time passes ]
laney@nightingale> juju status
0        down          pending  focal       Ubuntu SKUs for released stream not found

The cloud does have focal images present:

laney@nightingale> azure-cli vm image list --publisher Canonical --output table --all | grep 20.04
0001-com-ubuntu-server-focal          Canonical    20_04-lts                     Canonical:0001-com-ubuntu-server-focal:20_04-lts:20.04.202004230                             20.04.202004230
0001-com-ubuntu-server-focal          Canonical    20_04-lts                     Canonical:0001-com-ubuntu-server-focal:20_04-lts:20.04.202005010                             20.04.202005010
0001-com-ubuntu-server-focal          Canonical    20_04-lts-gen2                Canonical:0001-com-ubuntu-server-focal:20_04-lts-gen2:20.04.202004230                        20.04.202004230

Am I missing something in my invocations or is Azure not ready for focal yet?

Sorry for the shameless bump, but shameless bump hopefully during working hours.

Hi, @laney. Apologies for the delay getting back to you. There’s an issue w/ the way that azure instances are referenced in Juju due to some changes in the way they reference SKUs. Juju 2.8 and 2.7.7 should contain fixes when they land. For now, deploying focal images on Azure will be broken. :-/

1 Like

Oho yes, 2.8-rc2 works fine, thanks!