AWS spaces in 2.8

The spaces constraint seems to be broken in 2.8 on aws. see here

I believe there was a patch to make it so that application bindings that then imply spaces make sure to get passed on to underlying machines. Its plausible that something there broke passing through raw constraints about spaces.
Have you tried doing some form of

juju deploy --bind 'nat' application


juju deploy application --constraints spaces=nat

@jameinel thats it. juju deploy --bind 'nat' application gives the equivalent of what using the spaces constraint did previously. Thanks!

Using constraints should still work. I’ll look at this.

1 Like

Still seems that a fix to the space constraint is warranted :slight_smile: thanks Joe

I’m having issues with bootstrap not using the correct subnet also.

The following command previously worked, but now, using 2.8 it seems to just pick a random subnet. I can no longer bootstrap to the subnet I want to target.

juju bootstrap aws --credential mycred --to subnet=subnet-02bc060304e2d7916

^ seems to put the controller in a random subnet, paying no respect to the --to.

Not sure if this should be a separate bug or not, possibly its related to the code in the constraints regression.

I don’t think this is related.

I could not reproduce either with 2.8.1 or the current 2.8.2 edge. I did around 6 bootstraps that all landed in the requested subnet.

Can you create a LP bug with the output run with --debug?

1 Like